weitere Rubriken
PhilosophieTräumeOrteEsoterikLiteraturHelpdeskAstronomieGruppenSpieleGamingFilmeMusikClashVerbesserungenAllmysteryWillkommenEnglishGelöscht
Diskussions-Übersichten
BesuchtTeilgenommenAlleNeueGeschlossenLesenswertSchlüsselwörter
Schiebe oft benutzte Tabs in die Navigationsleiste (zurücksetzen).

Linux Talk

3.148 Beiträge, Schlüsselwörter: Android, Linux, Betriebssystem, Ubuntu, OS, Gnome, Unity, GNU, Kali, Debian, Open Source + 33 weitere

Linux Talk

10.07.2013 um 21:29
@RaChXa
Ich hab jetzt die interne IP des routers genommen und den "Intense Scan" gewählt.

Ich krieg nun das raus

Starting Nmap 6.00 ( http://nmap.org ) at 2013-07-10 21:28 CEST
NSE: Loaded 93 scripts for scanning.
NSE: Script Pre-scanning.
Invalid host expression: http://192.168.1.1/ -- colons only allowed in IPv6 addresses, and then you need the -6 switch
NSE: Script Post-scanning.
Read data files from: /usr/bin/../share/nmap
WARNING: No targets were specified, so 0 hosts scanned.
Nmap done: 0 IP addresses (0 hosts up) scanned in 1.41 seconds
Raw packets sent: 0 (0B) | Rcvd: 0 (0B)


melden
Anzeige

Linux Talk

10.07.2013 um 21:33
@rutZ
rutZ schrieb:WARNING: No targets were specified, so 0 hosts scanned
Hast du es richtig eingegeben?
nmap speedport.ip


melden

Linux Talk

10.07.2013 um 21:43
rutZ schrieb:Invalid host expression: http://192.168.1.1/
http ist ein Protokoll, das gibt man nicht mit an. Du willst ja den Host scannen und anhand der Ports schauen für welche Protokolle der Host einen Server anbietet.
Willst du nur schauen ob ein http-Server läuft kannst du auch angeben dass nur auf Port 80 gescannt wird, aber ein Protokoll gibt man nie mit an.


melden

Linux Talk

10.07.2013 um 21:44
@RaChXa
Ich hab die IP genommen http://192.168.1.1/ - Okay. Das nächste mal kein http mit reinnehmen

Aaaah..mit speedport.ip kommt raus:

Starting Nmap 6.00 ( http://nmap.org ) at 2013-07-10 21:35 CEST
NSE: Loaded 93 scripts for scanning.
NSE: Script Pre-scanning.
Initiating ARP Ping Scan at 21:35
Scanning speedport.ip (192.168.1.1) [1 port]
Completed ARP Ping Scan at 21:35, 0.01s elapsed (1 total hosts)
Initiating Parallel DNS resolution of 1 host. at 21:35
Completed Parallel DNS resolution of 1 host. at 21:35, 0.27s elapsed
Initiating SYN Stealth Scan at 21:35
Scanning speedport.ip (192.168.1.1) [1000 ports]
Discovered open port 80/tcp on 192.168.1.1
Completed SYN Stealth Scan at 21:35, 1.51s elapsed (1000 total ports)
Initiating Service scan at 21:35
Scanning 1 service on speedport.ip (192.168.1.1)
Completed Service scan at 21:37, 99.32s elapsed (1 service on 1 host)
Initiating OS detection (try #1) against speedport.ip (192.168.1.1)
NSE: Script scanning 192.168.1.1.
Initiating NSE at 21:37
Completed NSE at 21:38, 72.74s elapsed
Nmap scan report for speedport.ip (192.168.1.1)
Host is up (0.0028s latency).
Not shown: 996 closed ports
PORT STATE SERVICE VERSION
22/tcp filtered ssh
23/tcp filtered telnet
80/tcp open http?
|_http-title: Router
|_http-favicon: Unknown favicon MD5: E7CEDD76CB2D92B9E217D7C26A051D4D
631/tcp filtered ipp
1 service unrecognized despite returning data. If you know the service/version, please submit the following fingerprint at http://www.insecure.org/cgi-bin/servicefp-submit.cgi :
SF-Port80-TCP:V=6.00%I=7%D=7/10%Time=51DDB7A0%P=i686-pc-linux-gnu%r(GetReq
SF:uest,57EE,"HTTP/1\.1\x20200\x20OK\r\nCACHE-CONTROL:\x20no-cache\r\nDate
SF::\x20Wed,\x2010\x20Jul\x202013\x2019:35:59\x20GMT\r\nConnection:\x20Kee
SF:p-Alive\r\nContent-Type:\x20text/html\r\nContent-Length:\x2022357\r\n\r
SF:\n\n<head>\n<link\x20rel=\"icon\"\x20type=\"image/vnd\.microsoft\
SF:.icon\"\x20href=\"/images/favicon\.ico\"\x20/>\n<meta\x20http-equiv=\"C
SF:ontent-Type\"\x20content=\"text/html;\x20charset=utf-8\"\x20/>\n<title>
SF:\x20Router\x20</title>\n<script\x20type=\"text/javascript\"\x20src=\"/j
SF:s/loadbyver\.js\?ver=V100R001C748SP101\"></script>\n<script\x20type=\"t
SF:ext/javascript\">\nloadCss\(\"/lang/lang\.css\"\);\nloadRes\(\"/lang/ms
SF:gerrcode\.res\"\);\nloadRes\(\"/lang/wan\.res\"\);\nloadJs\(\"/js/util\
SF:.js\"\);\nloadJs\(\"/js/util/base\.js\"\);\nloadRes\(\"/lang/sim_lock\.
SF:res\"\);\n</script>\n<style\x20type=\"text/css\">\n\.STYLE1\x20{\nfont-
SF:size:\x2012px;\nfont-family:\x20Arial;\n}\na\x20{\ncolor:\x20#000000;\n
SF:cursor:\x20hand;\nfont-family:\x20Arial;\nfont-size:\x2014px;\ntext-dec
SF:oration:\x20none;\n}\ntd\x20{\nfont-family:\x20Arial;\nfont-size:\x2014
SF:px;\n}\na:hover\x20{\ncolor:\x20#990000;\n}\nbody\x20{\nmargin:\x200\x2
SF:00\x200\x200;")%r(FourOhFourRequest,27C,"HTTP/1\.1\x20200\x20OK\r\nDate
SF::\x20Wed,\x2010\x20Jul\x202013\x2019:36:05\x20GMT\r\nConnection:\x20Kee
SF:p-Alive\r\nContent-Type:\x20text/html\r\nCACHE-CONTROL:\x20no-cache\r\n
SF:Content-Length:\x20485\r\n\r\n\n<head>\n<meta\x20http-equiv=\"Con
SF:tent-Type\"\x20content=\"text/html;\x20charset=utf-8\"\x20/>\n<title>re
SF:place</title>\n\n<script\x20language=\"JavaScript\"\x20type=\"tex
SF:t/javascript\">\nvar\x20pageName\x20=\x20'/';\nif\x20\('/'\x20==\x20pag
SF:eName\x20\|\|\x20pageName\.indexOf\('content\.asp'\)\x20!=\x20-1\)\n{\n
SF:if\(pageName\.indexOf\('content\.asp'\)\x20!=\x20-1\)\n{\ntop\.location
SF:\.replace\(pageName\x20\+\x20\"\?rid=\"\x20\+\x20Math\.random\(\)\);\n}
SF:\nelse\n{\ntop\.location\.replace\(pageName\);\n}\n}\nelse\n{\ntop\.con
SF:tentfrm\.location\.replace\(pageName\);\n}\n</script>\n</head>\n
SF:\n\n");
MAC Address: F8:01:13:C1:A8:99 (Unknown)
Device type: general purpose
Running: Linux 2.6.X
OS CPE: cpe:/o:linux:kernel:2.6
OS details: Linux 2.6.9 - 2.6.27
Uptime guess: 0.058 days (since Wed Jul 10 20:15:20 2013)
Network Distance: 1 hop
TCP Sequence Prediction: Difficulty=199 (Good luck!)
IP ID Sequence Generation: All zeros

TRACEROUTE
HOP RTT ADDRESS
1 2.81 ms 192.168.1.1

NSE: Script Post-scanning.
Read data files from: /usr/bin/../share/nmap
OS and Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 178.39 seconds
Raw packets sent: 1029 (46.118KB) | Rcvd: 1011 (41.122KB)


melden

Linux Talk

10.07.2013 um 21:57
Wichtig ist erstmal das hier:

22/tcp filtered ssh
23/tcp filtered telnet
80/tcp open http?
|_http-title: Router
|_http-favicon: Unknown favicon MD5: E7CEDD76CB2D92B9E217D7C26A051D4D

Port 80 ist offen und sollte also eigentlich auch über einen http-Client (= Browser) erreichbar sein.


melden

Linux Talk

10.07.2013 um 22:01
Ja. Wie gesagt: Unter Win lief es ja


melden

Linux Talk

10.07.2013 um 22:12
@rutZ

Naja ich kann dir sagen was ich machen würde, wenn ich ansonsten gar keine Idee mehr hätte, aber die ganzen Abläufe dafür lassen sich über ein Forum schlecht beschreiben.
Ich würde mir während einem http-request mit Wireshark anschauen an welcher Stelle in der Kommunikation was schief geht.

Vielleicht hat jemand anderes noch eine Idee.


melden

Linux Talk

11.07.2013 um 00:15
@rutZ

Da http ein ASCII-Protokoll auf Applicationlayer ist, könntest du auch mit netcat über ein tcp-socket direkt eine Verbindung zum http-Server des Routers herstellen und dann manuell ein http-Request modellieren.

Also:
echo -e "GET HTTP/1.1\r\nHost: 192.168.1.1\r\n\r\n" | nc -vv 192.168.1.1 80

Nur mal um zu gucken was passiert. :D Aussagekräftig wäre vielleicht der Header der http-Response, falls du überhaupt einen Response erhältst.
rutZ schrieb:Also bei dem was ich gefunden habe, musste irgendwas in einer Konfigurationsdatei eingetragen werden. Aber wie gesagt, das war Slackware
Hast du den Link noch?


melden

Linux Talk

11.07.2013 um 00:53
RaChXa schrieb:echo -e "GET HTTP/1.1\r\nHost: 192.168.1.1\r\n\r\n" | nc -vv 192.168.1.1 80
192.168.1.1: inverse host lookup failed: Unknown host
(UNKNOWN) [192.168.1.1] 80 (http) : Connection timed out
sent 0, rcvd 0



Ja..der hier:

http://www.unixboard.de/vb3/showthread.php?51063-NFS-via-Speedport&p=366852&viewfull=1#post366852

Und der:
http://www.linux-club.de/viewtopic.php?f=15&t=116433


melden

Linux Talk

11.07.2013 um 01:15
@rutZ

Wenn ich das beim überfliegen richtig gesehen habe betrifft das nur die Namensauflösung.
Falls die Namensauflösung aus irgendeinem Grund nicht Funktionieren sollte kannst du natürlich in
/etc/hosts den Eintrag 192.168.1.1 speedport.ip Hinzufügen z.B. mit
# echo "192.168.1.1 speedport.ip" >> /etc/hosts

Aber ich denke das wird das Problem nicht lösen. Beim ping und nmap funktioniert die Namensauflösung ja auch außerdem im Browser lässt sich der Speedport auch über die ip-Adresse ebenfalls nicht erreichen.
rutZ schrieb:192.168.1.1: inverse host lookup failed: Unknown host
(UNKNOWN) [192.168.1.1] 80 (http) : Connection timed out
sent 0, rcvd 0
Hmm ...??? Versuche mal:

echo -e "GET / HTTP/1.1\r\nHost:\r\n\r\n" | nc -vv 192.168.1.1 80

und

wget --server-respons 192.168.1.1

Ansonsten weiß ich auch nicht mehr

Um sicher zu gehen poste doch vielleicht doch noch deine Filterregeln (als root: )
iptables -L
Sollte eigentlich leer sein.


melden

Linux Talk

11.07.2013 um 01:30
/etc/hosts den Eintrag 192.168.1.1 speedport.ip Hinzufügen z.B. mit
# echo "192.168.1.1 speedport.ip" >> /etc/hosts
Funktioniert auch nicht
RaChXa schrieb:echo -e "GET / HTTP/1.1\r\nHost:\r\n\r\n" | nc -vv 192.168.1.1 80
luckyluke@luckyluke:~$ echo -e "GET / HTTP/1.1\r\nHost:\r\n\r\n" | nc -vv 192.168.1.1 80
192.168.1.1: inverse host lookup failed: Unknown host
RaChXa schrieb:wget --server-respons 192.168.1.1
Kriegt keine Verbindung hin:
--2013-07-11 01:27:43-- http://192.168.1.1/
Verbindungsaufbau zu 192.168.1.1:80... fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen.
Erneuter Versuch.

--2013-07-11 01:28:47-- (Versuch: 2) http://192.168.1.1/
Verbindungsaufbau zu 192.168.1.1:80... fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen.
Erneuter Versuch.

--2013-07-11 01:29:52-- (Versuch: 3) http://192.168.1.1/
Verbindungsaufbau zu 192.168.1.1:80...

sudo iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


melden

Linux Talk

11.07.2013 um 01:34
@rutZ
rutZ schrieb:Funktioniert auch nicht
ok, habe jetzt auch erstmal keine Idee mehr.


(PS: # vor dem Befehl heißt als root ausführen. $ vor dem Befehl heißt als User ausführen)


melden

Linux Talk

11.07.2013 um 01:50
Bzw. hat es grade funktioniert. Nu isses wieder hin glaub ich. Von wegen connection timed out. Aber das liegt vielleicht an meinem unterirdisch schlechten Internet heute nacht.


melden

Linux Talk

11.07.2013 um 01:52
Oder es lag doch am /etc/hosts und es ging nur nicht, weil ich den browser nicht neugestartet habe oder so. Hab ich bei networks gemacht.
Ich habs jetzt bei beiden drinstehen :D


melden

Linux Talk

11.07.2013 um 02:01
@rutZ
rutZ schrieb:Oder es lag doch am /etc/hosts und es ging nur nicht, weil ich den browser nicht neugestartet habe oder so. Hab ich bei networks gemacht.
Ich habs jetzt bei beiden drinstehen :D
Für mich nicht ganz nachvollziehbar, warum es an der Namensauflösung lag. Kannst du das vielleicht (später) nochmal testen (die Zeile in /etc/networks mit einen vorangestellten # auskommentieren) und schreiben woran es lag.


melden

Linux Talk

11.07.2013 um 02:05
@RaChXa
Werd ich dann nochmal machen - Gegen Mittag/Nachmittag. Wie gesagt, unterirdisches Netz grade.

Bis Morgen :)


melden

Linux Talk

11.07.2013 um 02:15
rutZ schrieb:Werd ich dann nochmal machen - Gegen Mittag/Nachmittag. Wie gesagt, unterirdisches Netz grade.

Bis Morgen :)
okay, bis Morgen (oder Heute :D)


melden

Linux Talk

11.07.2013 um 02:22
@RaChXa
Grade ist das Internet doch ganz passabel.
Und ich muss sagen, du hattest recht. Es liegt in der datei /etc/hosts/. Als ich es geändert habe, musste ich aber den Browser eben neu starten, was ich vorhin nciht getan habe.



Zusammenfassung des Lösungswegs:

-Ordner /etc/ öffnen
-Datei "hosts" öffnen (root)
-Folgendes hinzufügen:

192.168.1.1 speedport.ip


-Speichern.
-Browser neustarten

Voi lá - Schon ist der Telekom Speedport mit IP drinne und man kann ihn über den Browser aufrufen. Keine probleme mehr.


Oder wie RaChXa es eben sagte

Falls die Namensauflösung aus irgendeinem Grund nicht Funktionieren sollte kannst du natürlich in
/etc/hosts den Eintrag 192.168.1.1 speedport.ip Hinzufügen z.B. mit
# echo "192.168.1.1 speedport.ip" >> /etc/hosts


melden
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

11.07.2013 um 11:47
Ich habe versucht, mein Fedora 18 auf 19 zu aktualisieren. Nach dieser Anleitung bin ich vorgegangen:

http://fedoraproject.org/wiki/FedUp#How_Can_I_Upgrade_My_System_with_FedUp.3F

Ich habe mir die .iso geladen und alles gemacht, was da steht. Nur kriege ich als Ausgabe von der Shell leider nur das zu lesen:
setting up repos...
Error: can't get boot images.
The 'fedupiso' repo was rejected by yum as invalid.
The given ISO probably isn't an install DVD image.
Bitte um Hilfe. :)


melden
Anzeige

Linux Talk

11.07.2013 um 12:58
@El_Gato

Du benutzt eine ISO File als Repo. - Bist du darauf angewiesen das so zu machen? Dort steht:
It is strongly recommended to use the network upgrade instead of offline update modes (ISO, local device). Network upgrade will ensure you receive the latest packages from Fedora 19. If you use local media containing old Fedora 19 packages, you might end up with a mixture of Fedora 18 and Fedora 19 packages and the system might not work properly until you fully update it after reboot (if it boots at all).
Würde ich falls möglich also auch so machen.


melden
329 Mitglieder anwesend
Konto erstellen
Allmystery Newsletter
Alle zwei Wochen
die beliebtesten
Diskussionen per E-Mail.

Themenverwandt
Konsolen in 50 Jahren180 Beiträge
Anzeigen ausblenden