weitere Rubriken
PhilosophieTräumeOrteEsoterikLiteraturAstronomieHelpdeskGruppenSpieleGamingFilmeMusikClashVerbesserungenAllmysteryWillkommenEnglishGelöscht
Diskussions-Übersichten
BesuchtTeilgenommenAlleNeueGeschlossenLesenswertSchlüsselwörter
Schiebe oft benutzte Tabs in die Navigationsleiste (zurücksetzen).

Linux Talk

3.148 Beiträge, Schlüsselwörter: Android, Linux, Betriebssystem, Ubuntu, OS, Gnome, GNU, Unity, Open Source, Mint, Opensuse + 33 weitere
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 13:14
Kann mir mal bitte jemand helfen? Ich versuche gerade, Cyanogenmod auf meinem Sony Ericsson Xperia Neo V zu installieren, scheitere aber schon ganz zu Anfang:

http://wiki.cyanogenmod.org/w/Fastboot#.22Command_not_found.22_errors

Ich habe das gemacht, was auf dieser Seite steht und IMMER sagt er mir "command not found"!


melden
Anzeige
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 13:21
Ach ja so sieht dann die .bashrc File aus:
# .bashrc

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi

# User specific aliases and functions

export PATH=${PATH}:/home/user/Development/adt-bundle-linux-x86-20130717/sdk/platform-tools/:/home/user/Development/adt-bundle-linux-x86-20130717/sdk/platform-tools/


melden

Linux Talk

23.07.2013 um 13:25
@El_Gato

Ich kenne das System nicht, aber wie dort schon steht, kann es sein dass die ausführbare Datei fastboot nicht im "path of execution" gefunden werden kann.

Schau mal im Verzeichnis /platform-tools ob die Datei vorhanden ist. Du kannst sie dann über eine absolute Pfadangabe starten


melden
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 13:26
@RaChXa

Natürlich ist sie vorhanden.
Du kannst sie dann über eine absolute Pathangabe starten
Öhm, was genau? Sorry, ich bin kein Profi... :vv:


melden

Linux Talk

23.07.2013 um 13:32
@El_Gato
El_Gato schrieb:Öhm, was genau? Sorry, ich bin kein Profi... :vv:
einfach die Datei mit absoluter Pfadangabe aufrufen:

/platform-tools/fastboot

Oder wenn du dich im Verzeichnis platform-tools befindest
./fastboot


( . steht für das aktuelle Arbeitsverzeichnis )


melden

Linux Talk

23.07.2013 um 13:34
El_Gato schrieb:Ich habe das gemacht, was auf dieser Seite steht und IMMER sagt er mir "command not found"!
Hast du nach dem Ändern der /etc/bashrc die Shell neu gestartet? Entweder aktuelle Shell beenden und neu starten, oder in der Kommandozeile mit "bash" einfach eine neue starten..
El_Gato schrieb:Öhm, was genau? Sorry, ich bin kein Profi...
Statt

fastboot

das hier:

/home/user/Development/adt-bundle-linux-x86-20130717/sdk/platform-tools/fastboot

(oder mit dem anderen Pfad). /platform-tools/fastboot dürfte es allerdings nicht geben.

Zäld


melden
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 13:40
@zaeld

Die Shell neu zu starten hat ein bisschen was gebracht. Insofern ein bisschen was, als daß er nach dem Befehl fastboot -i 0x0fce getvar version < waiting for device > ausgibt aber wenn ich diesen Befehl dann als sudo ausführen will, kommt er mir wieder mit der alten Scheiße:

command not found...


melden

Linux Talk

23.07.2013 um 13:40
zaeld schrieb:. /platform-tools/fastboot dürfte es allerdings nicht geben.
Ja das wäre im root Verzeichnis.
Musst halt schauen wo sich die Datei bei dir befindet @El_Gato und dann über den absoluten Pfard aufrufen.


melden
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 13:45
Ach das bringt ALLES nichts! Egal was ich mache, "command not found, command not found"!

BLÖDER DRECK!


melden

Linux Talk

23.07.2013 um 13:48
Hast du denn schon "sudo /home/user/Development/adt-bundle-linux-x86-20130717/sdk/platform-tools/fastboot" aufgerufen? Und alternativ mit dem anderen Pfad, den du da eingetragen hast?


melden

Linux Talk

23.07.2013 um 13:50
@El_Gato

sudo /home/user/Development/adt-bundle-linux-x86-20130717/sdk/platform-tools/fastboot

Geht nicht?


melden
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 13:51
@zaeld
@RaChXa

Nein... Das gibt er bei dem Befehl aus:
usage: fastboot [ <option> ] <command>

commands:
update <filename> reflash device from update.zip
flashall flash boot + recovery + system
flash <partition> [ <filename> ] write a file to a flash partition
erase <partition> erase a flash partition
format <partition> format a flash partition
getvar <variable> display a bootloader variable
boot <kernel> [ <ramdisk> ] download and boot kernel
flash:raw boot <kernel> [ <ramdisk> ] create bootimage and flash it
devices list all connected devices
continue continue with autoboot
reboot reboot device normally
reboot-bootloader reboot device into bootloader
help show this help message

options:
-w erase userdata and cache (and format
if supported by partition type)
-u do not first erase partition before
formatting
-s <specific device> specify device serial number
or path to device port
-l with "devices", lists device paths
-p <product> specify product name
-c <cmdline> override kernel commandline
-i <vendor id> specify a custom USB vendor id
-b <base_addr> specify a custom kernel base address
-n <page size> specify the nand page size. default: 2048
-S <size>[K|M|G] automatically sparse files greater than
size. 0 to disable


melden

Linux Talk

23.07.2013 um 13:52
@El_Gato

Ist doch richtig


melden
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 13:55
@RaChXa

Ja nur leider bringt mir das nichts. Ich muss um Cyanogenmod überhaupt installieren zu können, dieser Anleitung hier folgen:

http://wiki.cyanogenmod.org/w/Install_CM_for_haida#Obtaining_the_Bootloader_Unlock_Code

Und beim Befehl fastboot -i 0x0fce getvar version (als sudo) sagt er halt "command not found".
Ohne sudo scheint das zu gehen, denn da gibt er aus, was er ausgeben soll, nämlich < waiting for device >.

Was soll ich davon halten? Scheiss Technik, NIE tut sie das was sie verdammt noch einmal zu tun hat!


melden

Linux Talk

23.07.2013 um 13:57
sudo /home/user/Development/adt-bundle-linux-x86-20130717/sdk/platform-tools/fastboot astboot -i 0x0fce getvar version


melden

Linux Talk

23.07.2013 um 13:58
Natürlich ohne "astboot"...


melden

Linux Talk

23.07.2013 um 14:02
@zaeld

Ups beim einfügen nicht aufgepasst.

@El_Gato

Musst halt immer den absoluten Pfad mit angeben oder du richtest es so ein dass er die Datei ohne Pfadangabe findet.


melden
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 14:02
@zaeld
@RaChXa

Vielen Dank euch beiden, jetzt hats geklappt. :)


melden

Linux Talk

23.07.2013 um 14:31
Das Wachstum auf http://www.indiegogo.com/projects/ubuntu-edge hat sich doch arg abgeflacht.
Früher als ich erwartet hätte.


melden
Anzeige
El_Gato
ehemaliges Mitglied

Lesezeichen setzen

Linux Talk

23.07.2013 um 14:43
@mchomer

Stimmt schon. Aber noch haben sie 30 Tage Zeit und bis dahin könnte noch ordentlich was gehen.


melden
97 Mitglieder anwesend
Konto erstellen
Allmystery Newsletter
Alle zwei Wochen
die beliebtesten
Diskussionen per E-Mail.

Themenverwandt
Anzeigen ausblenden